I set up a class wiki.  As my students edit, it deletes the last post and only saves the latest post.  I am trying to use this as a brainstorming tool.  Does anyone know why this is occurring? 

Views: 57

Reply to This

Replies to This Discussion

Hi Russell, which wiki software are you using?

I'm not aware of "posts" in most wikis, there usually are collaborative pages that anyone can edit.
It might very well be that your student is actually editing the whole page.
Yes Joel, you're correct, but in editing the pages can students build upon what the others have written? I want my students to generate a list of topics to research. I had each student include two or three possible topics. They were all editing simultaneously. As they were doing this and pressing "save", the only thing saved to the page was the last person's suggestion who pressed "saved".
It looks like concurrency or locking issues. sorry to ask again but what wiki are you using? Maybe if we know which one we could be more helpful. Most wikis usually handle concurrency by locking the page (e.g. only one person can edit at a time, the others must wait) but some are better at working concurrently in real time and to merge the edits. Maybe yours has options to enable locking somewhere?
It is a concurrency issue. I'm not sure which Wiki I'm using, but it is for the Mac OSX Server. Today, I had one student type and "Save", then I had everyone refresh, then the next person typed and "Saved" and then everyone refreshed, etc. It worked, but it wasn't very efficient. I will look for options to enable locking. Thanks for your assistance.
Sounds like you are using the OS 10.6 Server software with Wiki option, not a service like Wikisapces (meaning you have to do a lot more customization yourself).

I'm not super familiar with it but I believe there is a permissions setting on it allowing for multiple edits (you might need unique user accounts on the server in order to make it work).

I'm out of my lab, but when I get in front of my server I'll check the settings...
Thanks Christopher! Yes, it is the OS 10.6 software with the Wiki option. I've checked in the settings and have not come across a setting that allows for multiple edits. I will continue to search, though.
Still not in my lab, so haven't been able to check but some quick Googling found OS 10.6 Server wiki issues when using LDAP connections.

Probably wont be able to check my server until tomorrow unfortunately, sorry.
Hi Russell,

Are you using Wikispaces? One of my teachers is having the same problem. She is having the students go to the history page and copy from there to restore postings. What a hassle! This has all occurred since returning from summer break and updating to IE8 and installing Microsoft Office 2010. Have you made any of these changes?

I use Wikispaces and haven't had this issue, however, I have noticed some changes since updating to Internet Explorer 8. We used to be able to copy from a document or somewhere else and paste into the wiki. Now we have to 'control v', which is new.

All I can say is that if you copy the address of your page and email help at Wikispaces, they are very helpful. I am interested in hearing what they say to you.

Good luck!

Thank you for your reply Debbie. I'm not using Wikispaces, I'm using the Mac 10.6 software.
I have had more success with both of the areas mentioned here when i have set up the document with a table for the area for students to work in. They work in a specifc cell in the table and the programs seem to handel the multiple users and edits better.



Win at School

Commercial Policy

If you are representing a commercial entity, please see the specific guidelines on your participation.





© 2020   Created by Steve Hargadon.   Powered by

Badges  |  Report an Issue  |  Terms of Service